Skip to content

Database Editor

The Kvaser Database Editor, developed by Kvaser, is embedded within CANtrace. It is installed automatically during the CANtrace installation process.

Note on Uninstallation

The Kvaser Database Editor is not automatically removed when you uninstall CANtrace. If you wish to remove it, you must do so manually via the Windows Control Panel.


Opening the Editor

You can access the tool in two ways:

  • Select the menu Tools > Database Editor.
  • Press the Database Editor button Figure: Play Log File Settings on the main toolbar.

Usage and Help

To learn how to add, remove, or edit CAN messages and signals, please refer to the built-in help documentation inside the Kvaser Database Editor (accessible via Help > Contents).

Creating J1939 Databases

If you want to create a J1939 DBC file using Kvaser Database Editor (version 3 and newer):

  1. Go to the menu File > New.
  2. Select J1939 Template.